From 43283928d30252d3da095370911899b80e1d551b Mon Sep 17 00:00:00 2001
From: Ryze <ryze@noreply.code.thishorsie.rocks>
Date: Wed, 2 Oct 2024 21:56:51 +0300
Subject: [PATCH] Use pkgs with stackpkgs overlay

To access derivations from stackpkgs for building other packages in it via callPackage
---
 flake.nix | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/flake.nix b/flake.nix
index b2d7a90..8d8ca8d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,13 +8,15 @@
   outputs = { self, nixpkgs }:
   let
     system = "x86_64-linux";
+    overlay = import ./overlay.nix;
 
     pkgs = import nixpkgs {
       inherit system;
+      overlays = [ overlay ];
     };
   in
   {
     packages.${system} = pkgs.callPackage ./stackpkgs.nix {};
-    overlays.default = import ./overlay.nix;
+    overlays.default = overlay;
   };
 }